Enhanced Caller Profile Data Not Appending For All Expected Calls
Incident Report for Invoca
Resolved
We've seen no failures retrieving and applying ECP data to relevant calls since approximately 9:41am Pacific time. This issue should now be fully resolved.

All other areas of the platform are working as expected and no other platform features were impacted by this incident.
Posted Sep 21, 2020 - 10:10 PDT
Monitoring
The rate of failure for appending ECP data to calls has reduced to normal levels at or near 0. We are monitoring the situation to ensure the issue is completely resolved and no further errors are returned.
Posted Sep 21, 2020 - 09:54 PDT
Identified
We have identified an issue beginning at 8:25 am Pacific time that is preventing some qualified calls from getting enriched Enhanced Caller Profile data applied as expected. This is only impacting a minority of calls that would normally have Enhanced Caller Profiles explicitly enabled. All standard Invoca reporting and data fields are working as expected.

Campaigns that reference Enhanced Caller Profile data in the Call Treatment when routing calls may see degraded performance for the subset of calls missing data.

All other calls are routing as expected, and all other platform features are fully operational.
Posted Sep 21, 2020 - 09:11 PDT
This incident affected: Reporting (Enhanced Caller Profiles).