Sporadic Issues With Number Swapping and Dynamic Attribution Collection
Incident Report for Invoca
Resolved
All internal testing and monitoring is healthy, and we have external verification that the symptoms are no longer occurring. This issue has been resolved as of 8:52am Pacific time, March 4.
Posted Mar 04, 2020 - 10:32 PST
Monitoring
We have identified an issue with dynamic number swapping that has two potential symptoms:

1) Some numbers may not have swapped dynamically as expected in all circumstances
2) Some numbers, though they did swap, did not collect full attribution, resulting in missing Marketing Data in reporting.

This did not affect all calls or number swaps, and did not impact call routing or connections.

We believe this issue began at approximately 3:30pm Pacific time March 3rd, and our engineering team has recently deployed a fix that should resolve the issue and both symptoms listed above. We are closely monitoring to ensure the issue is completely resolved.

Update: 14:15 Pacific Time 3/4/20
This issue seems to have only impacted customers using the Auto-Created RingPools feature, or part of the Destinations beta program.
Posted Mar 04, 2020 - 09:02 PST
This incident affected: Reporting (Reporting).