We have successfully resolved the access issues impacting the www2.invoca.net URL. Users can now log in through their preferred access points without redirection.
If you continue to experience any difficulties, please reach out to our support team.
Posted Jan 29, 2026 - 14:20 PST
Identified
While we continue to investigate and work towards a permanent solution specific to the www2.invoca.net Invoca URL, we have verified all users can successfully access and log into the Invoca UI through the workaround by going to Invoca.net.
We will continue to provide updates as they become available.
Posted Jan 29, 2026 - 09:41 PST
Investigating
We are currently investigating intermittent user access to the Invoca UI based on the specific Invoca URL(www2.invoca.net) users are attempting to log in from. If you experience issues accessing the Invoca UI, please redirect and attempt to log in to Invoca.net. If you continue to experience access issues on Invoca.net, please notify our support team to further investigate.
Posted Jan 29, 2026 - 08:47 PST
This incident affected: Platform Accessibility (Platform Accessibility).