Invoca Platform Emails Delayed
Incident Report for Invoca
Resolved
We have confirmed that emails are being delivered as expected, and the queued email volume is being delivered. We'll continue to monitor the backlog until all messages have been delivered, but this incident is now resolved.
Posted May 16, 2020 - 09:26 PDT
Monitoring
We have identified the root cause of the issue preventing emails from being sent and rolled out corrective action. We are currently monitoring the queued email volume to ensure the notifications are now sending and the queue is diminishing.
Posted May 16, 2020 - 09:07 PDT
Investigating
We are currently investigating an issue preventing emails that would normally be generated by the platform from being delivered as expected. This may include new user invitations, password reset emails, and other notification emails. All emails should be queued and no information is lost, but the messages are not being sent.

We will provide more updates here as they are available.
Posted May 16, 2020 - 08:14 PDT