Voice Based and AI Signals Are Not Evaluating
Incident Report for Invoca
Postmortem

On Tuesday June 9, 2020 at 3:07pm PT Invoca’s operations monitoring systems alerted that Invoca was experiencing an issue with a 3rd party vendor that provides transcription services. The issue was confirmed by the 3rd party vendor and was subsequently resolved, and services restored by 5:23pm PT. Customers using Signal AI, Keyword Spotting and/or call redaction services were impacted by this incident.

A majority of calls received between approximately 2:55pm - 5:23pm PT were not evaluated for Signal AI, Keyword Spotting or redaction. Note: no recordings for calls that were to be redacted are available during the incident window for compliance reasons.

Invoca is committed to PCI compliance and does so by encrypting all data (as it is at rest and in flight), as well as processing all data in memory in real time (without storing). This allows us to maintain the highest standard of Enterprise grade safety and security.

All calls continued to route normally during the incident window and no other services were disrupted.

Posted Jun 11, 2020 - 13:42 PDT

Resolved
After careful monitoring, all Voice and AI Signals are evaluating as expected as of 17:23 Pacific time. This incident is fully resolved.
Posted Jun 09, 2020 - 18:21 PDT
Monitoring
Voice and AI Signals are now evaluating and approaching normal success rates. We are continuing to monitor the situation to ensure the issue is fully resolved.
Posted Jun 09, 2020 - 17:56 PDT
Update
We are continuing to monitor the situation and work toward a resolution.
Posted Jun 09, 2020 - 16:39 PDT
Identified
We have identified an issue that is preventing the evaluation of voice based Signals, beginning at approximately 14:55 Pacific time. AI Signals that rely on evaluation of voice phrases are also impacted for calls during this time period. We are actively working toward a resolution and will provide more details as they become available.

Call routing is not impacted and all other components of the Invoca platform are performing as expected.
Posted Jun 09, 2020 - 15:26 PDT
This incident affected: Signals (Signal AI Processing).