Conversion Processing Delays with Microsoft Ads Integrations
Incident Report for Invoca
Resolved
This incident has been resolved.
Posted Dec 22, 2023 - 15:05 PST
Monitoring
A fix has been made to streamline fulfilling the backlog of requests to Microsoft Ads. The backlog will likely require the remainder of today to complete.
Posted Dec 22, 2023 - 10:19 PST
Identified
We have identified an issue that is currently causing a delay in uploading call conversions to active Microsoft Ads integrations. All connections between Invoca Networks and Microsoft Ads are functional. The root cause of the issue has been identified and we're working to resolve it.
Posted Dec 22, 2023 - 06:47 PST
This incident affected: Integrations (Other Integrations).