Invoca UI Not Loading Correctly In Firefox or Safari
Incident Report for Invoca
Postmortem

Browser specific JavaScript implementations resulted in some browsers (Firefox & Safari) failing to evaluate some code.

Posted Feb 07, 2020 - 11:40 PST

Resolved
We have confirmed that the change fully resolved the issue, and all supported browsers should now work as expected when navigating across the Invoca platform.
Posted Dec 17, 2019 - 08:38 PST
Monitoring
We have implemented a change that has resolved the user interface issues with Firefox and Safari browsers. Our engineering team is monitoring the situation to ensure it is fully resolved.

All supported browsers should currently work as expected with Invoca.
Posted Dec 17, 2019 - 08:17 PST
Investigating
We are currently investigating an issue with the Invoca user interface not rendering correctly after logging in with Firefox or Safari. When navigating across the platform pages do not load complete information.

At this time Chrome does not appear to be affected. We recommend using Chrome as a work around while we investigate and work towards a resolution for this issue.
Posted Dec 17, 2019 - 08:06 PST
This incident affected: Reporting (Reporting).