We have observed normal call behavior to all Toll-Free destination lines for the past hour, and all services have returned to full stability. We are marking this incident as closed.
Posted Nov 03, 2025 - 14:30 PST
Identified
We are continuing to monitor the issue as we have not seen a reduction in the failure rate to Toll Free destination lines owned by this carrier and will continue to provide updates as more information becomes available.
Posted Nov 03, 2025 - 12:03 PST
Investigating
We have identified call connection failures specific to Toll Free destination lines owned by AT&T. At this time we have determined this to not be an Invoca specific issue and more broadly an AT&T issue.
We have opened tickets with our downstream providers for awareness and are continuing to monitor the issue.
Caller experience is long delays followed by a "number not in service" or "busy" message.