Subset of ECP Calls Missing Data Append
Incident Report for Invoca
Resolved
Invoca is now able to successfully retrieve data from Infutuor. This incident has been deemed resolved.

We are now evaluating methods to backfill any missing ECP data for any impacted Networks.
Posted Jun 01, 2020 - 13:17 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 01, 2020 - 13:14 PDT
Identified
Beginning on May 30th, 2020 at approximately 10:49 GMT, data from one of our demographic data providers, Infutor, stopped being applied as expected. As a result, calls since this time that would normally have had Enhanced Caller Profile (ECP) data applied may be missing expected expanded data points.
This has impacted a small subset of customers using ECP, all other ECP providers are unaffected.
Invoca Engineering is currently working on a fix to resolve the data append and looking into methods to backfill any missing data.

No routing or in-flight calls were impacted.
Posted Jun 01, 2020 - 11:39 PDT
This incident affected: Reporting (Enhanced Caller Profiles).