Google Ads Integration - degraded performance
Incident Report for Invoca
Resolved
This incident has been resolved.
Posted Sep 01, 2023 - 15:27 PDT
Monitoring
This incident has been resolved. Google Ads audiences are working as expected. The engineering team is actively monitoring.
Posted Sep 01, 2023 - 12:29 PDT
Update
Our engineering team has isolated the issue to ONLY customers that have enabled audiences in their Google Ads integration. In order to mitigate the issue, the team has restarted impacted customers’ Google Ads integrations without full Audience support. Engineering is working closely with our Google Partners to seek a resolution to the Audience support issue and pinpoint the root case. If you do not use audiences, you were not impacted and your Google Ads integration is working as expected.
Posted Aug 31, 2023 - 16:50 PDT
Update
The engineering team continues to investigate. We will provide updates as we work towards resolution.
Posted Aug 31, 2023 - 13:35 PDT
Identified
We have identified an issue where some customers’ Google Ads integrations are experiencing authentication issues resulting in call data not successfully posting to Google. The engineering team is actively addressing this issue and updates will be provided as we work towards resolution.
Posted Aug 31, 2023 - 12:22 PDT
Investigating
Our team is currently investigating an issue with the Google Ads integration.
Posted Aug 31, 2023 - 10:54 PDT
This incident affected: Integrations (Google Ads).