Google Ads Platform Issues
Incident Report for Invoca
Resolved
Google has restored all of its ads platform services.
Posted Jan 26, 2024 - 19:38 PST
Monitoring
Google continues to experience issues with its ad platforms. We've reviewed our logs for Google Ads and have not seen any significant increases in error rates. Our integration appears to be functioning as expected/not impacted.
Posted Jan 26, 2024 - 14:36 PST
Identified
Google has reported a Service Outage for a number of its advertising products including Google Ads, Google Analytics, and Search Ads 360. These issues may impact our ability to send and receive data from their platforms. Real-time information on the status of each Google platform can be found here: https://ads.google.com/status/publisher/
Posted Jan 26, 2024 - 12:58 PST
This incident affected: Integrations (Google Ads, Google Analytics, Other Integrations).