Inbound calls

Incident Report for Invoca

Resolved

This issue was mitigated at 11:41 am PST. Calls are routing as expected and our engineering team continues to monitor.
Posted Apr 07, 2026 - 11:50 PDT

Identified

We are currently investigating an issue impacting a large portion of inbound calls, which began at approximately 11:08 AM PST. The root cause has been identified, and our engineering team is actively implementing a fix. We will provide further updates as they become available.
Posted Apr 07, 2026 - 11:45 PDT
This incident affected: Call Routing.