Intermittent Access to the Customer Support Portal

Incident Report for Invoca

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 11:52 PST

Update

We are continuing to monitor for any further issues.
Posted Jan 22, 2026 - 07:55 PST

Monitoring

A fix has been implemented and we are monitoring results. Please resume accessing the Case Portal.
Posted Jan 22, 2026 - 07:54 PST

Investigating

We are currently investigating an issue that is preventing some users from accessing the Invoca Customer Support Portal.
Our team is working to restore full access as quickly as possible.

How to get help: Please send any technical requests or urgent issues to support@invoca.com.
Posted Jan 21, 2026 - 19:05 PST
This incident affected: Platform Accessibility (Platform Accessibility).