EU Platform Login Access Issue - 9/19/24
Incident Report for Invoca
Resolved
This incident has been resolved.
Posted Sep 19, 2024 - 14:31 PDT
Investigating
We are currently investigating an issue with users' ability to access our EU platform's UI. Our US platform is not impacted.
Posted Sep 19, 2024 - 14:16 PDT
This incident affected: Invoca Europe (Invoca Europe, Platform Accessibility).