This incident has been resolved. The disruption was caused by a hardware failure on one of our servers, which temporarily took our Dynamic Number Insertion and call attribution services offline. Our engineering team replaced the affected hardware, restored services, and confirmed full recovery
Impact Window: 5:50AM - 6:37AM PDT
Posted Jul 22, 2026 - 06:57 PDT
Monitoring
Our engineering team has identified and resolved the underlying issue. Services have been restarted and number swapping and call attribution are being restored. We are actively monitoring to confirm full recovery
Posted Jul 22, 2026 - 06:46 PDT
Investigating
We are currently investigating an issue affecting number swapping and call attribution across the Invoca platform. Customers may experience missing or delayed attribution data during this time.
Our engineering teams are actively working to restore service.
Posted Jul 22, 2026 - 06:13 PDT
This incident affected: Dynamic Number Insertion and Attribution.