Signal file processing delayed

Incident Report for Invoca

Resolved

Signal uploads are processing successfully.
Posted Jul 08, 2026 - 17:53 PDT

Update

We are continuing to monitor for any further issues.
Posted Jul 08, 2026 - 17:52 PDT

Monitoring

Signal file processing has now been resumed and we are monitoring to ensure all queued files are processed as expected.
Posted Jul 08, 2026 - 15:56 PDT

Investigating

Invoca is currently experiencing a delay in Signal file processing (both manual and automated file imports) beginning July 8, 2026 at 10:30 AM PT, with normal service expected to resume between 3:00–6:00 PM PT today. All files submitted during this window are queued and will process automatically with no action required. All other Signal-related services are operating normally.
Posted Jul 08, 2026 - 11:33 PDT
This incident affected: Signals (Signals).