Invoca User Interface Accessibility Issue - May 8, 2024
Incident Report for Invoca
Resolved
After further investigation, we have confirmed that no other aspects of the Invoca platform were impacted. This incident is now resolved.

The impact window for accessing the Invoca UI was 10:13 am-10:58 am Eastern Time (~45 minutes)
Posted May 08, 2024 - 08:52 PDT
Monitoring
A fix has been implemented and we are no longer seeing errors with accessibility. Now that access has been restored, we will internally review to understand whether any other aspects of our platform were impacted.
Posted May 08, 2024 - 08:05 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 08, 2024 - 07:59 PDT
Investigating
We are currently investigating an issue with users not being able to access aspects of the Invoca user interface.
Posted May 08, 2024 - 07:46 PDT
This incident affected: Platform Accessibility (Invoca UI).